Chat with us, powered by LiveChat

Blog

FX Synergy 1.5.1 Build 203 Released

We are very pleased to announce the release of FX Synergy 1.5.1 Build 203. This release is an emergency update to support the new MT4 version released by MetaQuotes last week.

If you have an active license with updates, simply start or restart FX Synergy and you will be asked to update to the latest version. All your settings will survive the update. Please remember to close all MT4 terminals before updating.

There are 2 very important things to note:

1) FX Synergy should be started before any MT4 terminals. If you start MT4 first, you may need to reload the FX Synergy template to connect the account.
2) MetaQuotes have messed up how plugins are initialised, so until they get the issue fixed you need to reload the FX Synergy template every time you start the MT4 terminal. The issue appears to have been fixed in MT4 Build 604, so it’s only temporary until your broker updates to the latest build.

Read more →

Issues Caused by New MT4 Update

On Monday, MetaQuotes released the new MT4 build 600, which have already been rolled out by a number of brokers. The update introduces a number of changes, which are already causing issues for virtually everyone developing software for MT4. The video below goes through the changes and the issues. We highly recommend that you watch it.



Read more →

FX Synergy 1.5.1 Build 201 Released

We are pleased to announce the release of FX Synergy 1.5.1 Build 201. This release adds 3 new features, and a few minor tweaks and improvements. FX Synergy is the most advanced MT4 trade manager.

If you have an active license, simply start or restart FX Synergy and you will be asked to update to the latest version (if your trial or update subscription has expired you won’t be able to use the new version). Please note that you will be asked to un-install your current version. This is normal. Your settings will survive. Please remember to close all MT4 terminals before updating.

The short video below covers the new features in FX Synergy 1.5.1 Build 201. We highly recommend that you check it out, and learn about the new features we have added.



Read more →

FX Synergy 1.5.1 Released

We are very pleased to announce the official release of FX Synergy 1.5.1, the most advanced MT4 trade manager.

If you have an active license, simply start or restart FX Synergy and you will be asked to update to the latest version (if your trial or update subscription has expired you won’t be able to use the new version). Please note that you will be asked to un-install your current version. This is normal. Your settings will survive. Please remember to close all MT4 terminals before updating.

Below is a video that showcases the new features we have added in FX Synergy 1.5.1. We highly recommend that you see it as it covers all the new features we have added.



Read more →

TradeStation Support for FX Synergy

We have mentioned on several occasions that FX Synergy was never designed to work only with MetaTrader. Over the past year we have been preparing the backend of FX Synergy to support other trading platforms, and we recently announced support for NinjaTrader, coming in Q1 2014.

Since we keep getting requests for TradeStation support as well, we have now decided to work on finalizing TradeStation support in Q2, 2014. Right after NinjaTrader and cTrader is supported, which is the most requested platforms.

This means that all features in FX Synergy will be available with TradeStation, and multi-account trading and trade copying will ofcourse be fully supported as well, so you can mix and match accounts on all supported platforms completely transparently.